1. Home
  2. Knowledge Base
  3. End of Support for PHP Versions Older than 7.4

End of Support for PHP Versions Older than 7.4

TL;DR PHP 5.6 was released 7 years ago and made obsolete 3 years ago. Do not use this.

If you see a warning message like this on your site, you need to contact your hosting provider and request that they upgrade your server to PHP 7.4 or higher. We fully support PHP 7.4, and run it locally ourselves. In fact, PHP 7.4 seems to run MemberMouse twice as fast as PHP 5.6 with no other changes, and MemberMouse as of 2.2.5 picks up the strong cryptographic functions native to PHP 7.4 (which makes passwords, sessions, and API keys significantly stronger).

There are some hosts who will tell you that they can't upgrade you to PHP 7.4. These hosts must be avoided at all costs. It means that the hosting company doesn't care about investing the minimal amount of time required to properly set up their machines and ensure your security.

MemberMouse 2.4.1+ is fully compatible with PHP 8. For those customers who wish to continue using MemberMouse 2.4.0, please download a fresh copy of the plugin and perform a manual upgrade before moving to PHP 8.

If you need help choosing a new hosting provider, read our article on WordPress hosting providers.

Was this article helpful?

Can’t find the answer you’re looking for?

Reach out to our Customer Success Team
Contact us!